0

Installed Qt WebEngine locales directory not found...

I keeping running into websites that will either, A) not load at all, or B) display incorrectly, on our XD232 units.

In every case that I am having these issues I find this error in the BrightPlayer log:

Installed Qt WebEngine locales directory not found at location /share/qt5/translations/qtwebengine_locales. Trying application directory...
[ 35.914] Qt WebEngine locales directory not found at location /bin/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[ 36.381] [0307/161518:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale

An example site that is not displaying properly and is generating this message is:

https://www.wsj.com/

Another one is:

http://www.apple.com/ca/

I have tried adding these sites as through a presentation in BrightAuthor as well as through this autorun:

Sub Main()
msgPort = CreateObject("roMessagePort")
r = CreateObject("roRectangle", 0, 0, 1920, 1080)
h = CreateObject("roHtmlWidget", r)
h.SetPort(msgPort)
h.SetURL("https://www.wsj.com/")
sleep(10000)
h.Show()
while true
msg = wait(0, msgPort)
print "type(msg)=";type(msg)
if type(msg) = "roHtmlWidgetEvent" then
eventData = msg.GetData()
if type(eventData) = "roAssociativeArray" and type(eventData.reason) = "roString" then
print "reason = ";eventData.reason
if eventData.reason = "load-error" then
print "message = ";eventData.message
endif
endif
endif
end while
End Sub

Why are none of these working? I can view the sites without issue on various computers.

 

34 comments

  • 0
    Avatar
    Lyndon

    Nathan,  I only see one ticket in our system under your name, and no others under you domain, so you're the only user at your domain I can find. I'm not sure if your other tickets submitted never made it into our system.

    If you can send support your presentation, we can test it. If your user-agent string change didn't work, this custom autorun here for ba 4.6.0.18 changes the string to match a windows 10 chrome browser.

    https://www.brightsignnetwork.com/download/Scripts/autoxml-46018-chrome.brs

    If clicking on the link doesn't work, paste it into your browser. 

     

    Also, if you haven't already done so, you should update firmware to 6.2. We upgraded the version of chromium we used between 6.1 and 6.2. So, some pages will definitely display differently between 6.1.100 and 6.2.94. 

     

     

     

     

  • 0
    Avatar
    Lyndon

     

    The wsj page, one issue, is it's using some images, possibly in backgrounds, that are too large for your xd1132. ON my 4k player, the page comes up. This is a screengrab from the remote snapshot on my 4k player. 

     

    But, my HD2 player, shows this error int he system log:

    [ 117.743] + msg received - type=roHtmlWidgetEvent
    [ 117.745] + reason = load-finished
    [ 118.389] Image too large: 2241x1400 @ 32bpp = 12549600 bytes, maximum permitted size is 10485760 bytes (2048x1280)
    [ 118.389] [0311/162930:INFO:SkError.cpp(84)] Skia Error: Unknown error: ---- failed to create texture for cache [1025 1025]

    The same may be true on the Apple page that there's content that's higher than HD resolution which your XD2 might not support. In general some websites may use canvases that are larger than your HD player support, and since PC's have so much memory, you'll find general websites that are sloppy with resource usage that will be more of a problem on your 1132 than your pc. 

     

    But in this case, it appears to be a problem with images too large for your xd player. I'll do some more testing, but that's what I've found in the first few minutes after publishing. I'll ask developers about the skia error. 

     

     

  • 0
    Avatar
    Lyndon

    On the wsj page, there also appears to a be a call to vidora javascript thta fails...

     

    [ 147.854] [WARNING][source https://vir.wsj.net/fp/cdn/fp/assets/602809b00b878bbdbcac/SectionPage.js:223]: Failed to fetch inset data
    [ 148.234] [INFO] [source https://assets.vidora.com/js/vidora-client.1.2.7.min.js:2]: vidora-client 1.2.7 70defd4dcf46f60d01ad6075900d8e0381a4299b

     

     

  • 0
    Avatar
    Nathan Beranger

    Hi Lyndon,

    Thanks for looking into this. From what you have said, it sounds like the major issue is the image size. I did notice that for sure when I looked at the console when I was trying to display Apple's site. I was able to get the custom user agent working, but I also tried with the one you supplied. As I had expected, it didn't make any difference.

    Also, just to be clear. We have XD232 players, not XD1132.

    We are hoping to upgrade a few of our units to XT1143 models in the near future.

    Regarding the ticket(s) you can't see, I'll ask my colleague to submit again.

Please sign in to leave a comment.