XC2055 brand new multiple issues, has not worked yet

XC2055 v9.0.59
First Major issue:
The player stopped displaying video. I have a 4K Dell P2715Q
I created a factory reset microSD. This fixed the issue. Although it is displaying 640x480 60Hz since it can't move beyond wanting a storage device inserted.

Second Major issue:
The player does not recognize a microSD formatted FAT32
I am using SanDisk 32GB Extreme microSDHC UHS-I C10, U3, V30, 4K, A1, SDSQXAF-032G-GN6MA, Red/Gold read speed 100 MB/s write 60 MB/s.
I ordered a faster microSD, waiting for it to arrive, hoping this will solve current issues: ADATA Premier One V90 microSD card read 275MB/s write 155MB/s

Third Major issue, internet connection:
Perhaps I need to get it to accept a microSD before I can get an internet connection.
Did not connect thru until multiple factory reset attempts.

I also made a setup micro SD drive with Bright Author, it acted like it worked but still can't publish.

I can ping the IP address from my PC.

When I try to search for the unit in order tp local publish through Brightsign it says:
The error message says Unable to access a Brightsign with that IP address

Where should I order 8K microSD cards?
Should I order MicroSD cards from Brightsign? The speeds are not listed. I can not tell if they support 8K.

1 comment

  • 0
    Jennifer Steinkamp

    Here are some tips for the XC2055:
    1) Use a fast enough SD card such as: ADATA Premier One V90 microSD card read 275MB/s write 155MB/s
    2) Format the card as ExFat
    3) Use this firmware or newer:
    4) If you do not have an 8K monitor, make your presentation 4K and you can see your 8K file cropped.

Please sign in to leave a comment.